Blog o PrestaShope a obchodovaní

Poplašná správa Websupportu o konci podpory PHP 5.6

Poskytovateľ webhostingových služieb, spoločnosť Websupport v posledných dňoch rozoslala svojim zákazníkom e-mail s nasledujúcim znením. Ak svoj web či e-shop máte na ich serveroch, čítajte ďalej.

Pekný deň,

viete o tom, že na Vašom hostingu používate staršiu verziu PHP 5.6, ktorej predĺžená oficiálna podpora definitívne skončila v decembri 2018? Prestala tým získavať bezpečnostné/opravné aktualizácie, takže na prevádzku dôležitého webu ju už neodporúčame.

PHP 5.6 ostane na našich serveroch dostupné aj v najbližšom roku, Vaša webová stránka bude bez akýchkoľvek zmien fungovať aj naďalej. Odporúčame Vám ale zvážiť bezplatnú aktualizáciu na jednu z podporovaných verzií PHP 7 (7.1 - 7.3, keďže podpora 7.0 skončila tiež), ktorá zvýši bezpečnosť Vašich webových stránok a radikálne zlepší výkon celého hostingu.

Ak používate niektorý z moderných redakčných systémov (napríklad WordPress), pre správne fungovanie webovej stránky by malo stačiť vykonať pred zmenou verzie PHP bežnú aktualizáciu redakčného systému a jeho súčastí.

Aby sme vám čo najviac zjednodušili testovanie, pripravili sme pre vás nástroj na bezpečné otestovanie Vašej webovej stránky bez vplyvu na živý web. Nájdete ho priamo vo WebAdmine.

Odporúčame Vám kontaktovať Vášho správcu webu/developera a informovať sa o možnostiach. Ak nikoho takého nemáte, môžete sa s otázkami obrátiť aj na nás, no úpravy na webe Vám z kapacitných dôvodov zabezpečiť nevieme.

Ďalšie informácie
- Návod na zmenu verzie PHP a ostatné odporúčania nájdete v báze znalostí: https://wbsprt.in/php56kbsk
- O starých verziách PHP sme napísali aj na našom blogu: https://wbsprt.in/php56blgsk

S pozdravom,
Karol Vörös, marketing & product
WebSupport.sk

Nakoľko sa na nás obrátilo veľké množstvo našich zákazníkov so žiadosťou o “preloženie” tohto oznamu do reči, ktorej by rozumeli v súvislosti s dopadom na ich web/e-shop, zvolili sme formu článku v ktorom si nájdete podľa verzie PrestaShopu, aký typ akcie sa od Vás vyžaduje. Dúfajme, že sa Websupport do budúcnosti vyhne oznamom v štýle poplašnej správy, ako je to v tomto prípade.

O čo ide?

Povedané v skratke:

  • minimálne tento rok nepotrebujete urobiť nič;
  • na základe verzie Vášho PrestaShopu, nemôžete nastaviť ľubovolnú PHP verziu servera ako sa Vám zachce a ako Vás k tomu vyzýva Websupport - výsledkom môže byť nefunkčný e-shop;
  • ukončenie podpory PHP 5.6 neznamená, že túto verziu nemôžete ďalej bez zmien na Vašej strane používať;
  • až keď Websupport oznámi vypínanie PHP 5.6 (najskôr až na ďalší rok, alebo aj neskôr), vtedy budete musieť zvoliť jeden zo scenárov nižšie.

Mám PrestaShop 1.7.x

Ak prevádzkujete PrestaShop 1.7, pravdepodobne Váš e-shop na PHP 7 a vyššej už beží. Pre PrestaShop 1.7.5.0 môžete nastaviť PHP 7.2. Na PHP 7.3 k dnešnému dňu ešte žiadny PrestaShop nefunguje. Aj keď nie je PrestaShop 1.7 veľmi stabilný, posledná verzia 1.7.5.0 je na tom už celkom dobre.

Mám PrestaShop 1.6.1.x

Posledná verzia (1.6.1.23) Vám bude fungovať na PHP 7.1. Problém môžu urobiť moduly tretích strán (samostatné, alebo potrebné pre šablónu tretej strany). Pri nefunkčnosti Vám odporúčame osloviť autora šablóny, alebo Vášho developera, aby nefunkčné moduly upravil tak, aby na PHP 7.1 fungovali.

Mám PrestaShop 1.6.0.x

Odporúčame urobiť upgrade (inováciu) minimálne na verziu PrestaShop 1.6.1.23 a nastavenie PHP 7.1. Keďže sa jedná o upgrade v rámci generácie systému, nie je potrebné v zásadnej miere riešiť komplikácie spojené s kompatibilitou šablóny a modulov tretích strán. Keďže ale spoločnosť Websupport PHP 5.6 zatiaľ nevypína, máte stále dostatok času a zachovať prevádzku v e-shope bez zmien.

Mám PrestaShop 1.5.x a starší

Odporúčame v dohľadnej dobe vykonať upgrade na PrestaShop 1.6.1.23 alebo 1.7.5.0, pretože Váš e-shop pravdepodobne beží dokonca na verzii staršej ako PHP 5.6. PrestaShop tejto generácie je zastaraný aj technologicky (nemá responzívnu šablónu, nevie korektne pracovať na SSL atď.).

Upgrade PrestaShopu

Upgrade medzi generáciami PrestaShopu si vyžaduje dostatočné skúsenosti. Benefitom procesu upgrade je zachovanie všetkých dát e-shopu, od katalógu, cez objednávky, zákazníkov a nastavenia systému. Oslovte nás preto, ak si prajete prejsť na novú generáciu systému. Na začiatku zhodnotíme stav v akom sa Váš e-shop nachádza, potom pripravíme cenovú ponuku a v prípade, že Vám bude vyhovovať, upgrade vykonáme.


Predchádzajúci článok: Postup implementácie SSL certifikátu do PrestaShopu

Kategórie

Spojte sa s nami

PrestaShop a celý jeho ekosystém sa neustále vyvíja a napreduje. Prijímajte od nás e-mailom aktuality o najnovších vydaniach, moduloch a doplnkoch.