Blog o PrestaShope a obchodovaní

Povedzte PrestaShopu 1.7 “nie”!

Možno si niekto z čitateľov tohto Blogu všimol, že sa v ňom veľmi, resp. vôbec nevenujeme PrestaShopu 1.7. Má to svoje dobré dôvody, ktoré ozrejmíme nižšie v článku.

Sú to už takmer 2 roky, čo bol PrestaShop 1.7 oficiálne vydaný ako stabilná verzia. Postupom času bolo oznámené, že predchádzajúca generácia PrestaShop 1.6 sa bude udržiavať do októbra 2018. Teda presne 2 roky od vydania 1.7. Tento termín sa neúprosne blíži a PrestaShop plány prekvapivo mení.

Obrázok: Povedzte PrestaShopu 1.7

Prečo povedať 1.7-čke nie?

Ako je všeobecne známe, PrestaShop 1.7 je "zlepený" z dvoch odlišných frameworkov. Časť PrestaShopu bola prepísaná do frameworku Symfony, ale zbytok zdieľa rovnaký kód, ako 1.6. Nielen tento fakt vyslúžil PrestaShopu 1.7 povesť nestabilného systému, nevhodného pre stavbu väčších, či komplikovanejších e-shopov. Samotné jadro systému obsahuje množstvo kritických chýb, ktoré Vám môžu privodiť stav, kedy Váš e-shop nebude predávať. Nie je zriedkavé, že Vám e-shop môže zo dňa na deň prestať fungovať a nikto nebude tušiť prečo. Keďže framework Symfony je zložitejší, ovláda ho podstatne menej developerov ako u doterajších verzií. Preto je obtiažnejšie nájsť firmu či jednotlivca, ktorý zabezpečí profesionálnu podporu, opravu chýb alebo vývoj nových funkcií.

Z tohoto dôvodu, my ako tvorca e-shopov, si nedovolíme našim klientom ponúknuť nestabilný systém, ktorý nebude vo výsledku plne funkčný, alebo ohrozí online biznis klienta, či spôsobí citeľné finančné a časové straty. Preto ponúkame stavbu a servis na PrestaShope 1.6 ako najlepšie riešenie tejto platformy.

V rámci PrestaShop 1.7 sa venujeme iba zabezpečeniu kompatibility našich modulov, ktoré nájdete v našej knižnici.

Tvrdohlavý PrestaShop

PrestaShop je tu už desiaty rok a bez prestávky sa vyvíja a zlepšuje. Úprimne, nie je to práve programátorský skvost, ale to nie je žiadny redakčný systém. V konkurencii s inými bezplatnými CMS sa naň nechytá ani jednoduchý OpenCart či moloch Magento. WooCommerce sa tu zahrnúť nedá, pretože je to len plugin WordPressu, ktorý vďaka svojej deravosti môže pripraviť nemilé bezpečnostné problémy. PrestaShop má veľmi dobrý pomer cena/výkon, ak chcete realizovať malý, alebo stredne veľký e-shop.

PrestaShop začal pre približne 4 rokmi tvoriť novú generáciu, nástupcu 1.6. Napriek tomu je 1.6 dodnes najstabilnejšou verziou PrestaShopu.

Spôsob, akým PrestaShop začal robiť manažérske rozhodnutia pre smerovanie vývoja systému nebral ohľad na kritické hlasy komunity. Nereflektoval (toho sa drží viacmenej dodnes) požiadavky obchodníkov na funkcionalitu.

Ukážkovým príkladom tvrdohlavosti je napríklad to, že napriek žiadostiam komunity odmieta vytvoriť systém Blogu ako integrálnu súčasť jadra PrestaShopu. Našou vecnou argumentáciou v tejto debate bolo, že funkcionalita, ktorá akýmkoľvek spôsobom ukladá obsah, by mala byť integrovaná v systéme, aby bola zaručená aktualizovateľnosť funkcionality v nasledujúcich generáciách. PrestaShop argumentuje, že je k dispozícii mnoho Blog modulov od developerov tretích strán. To je samozrejme pravda, ale ich autori nijako nedokážu garantovať, že ak máte napríklad na PrestaShope 1.5 modul Blogu, že pripraví aktualizáciu modulu pre novšie verzie PrestaShopu. V takom prípade vy ako obchodník prídete pri inovácii PrestaShopu o články v Blogu. Potom budete musieť zainvestovať opäť do nového modulu a nechať urobiť export a import článkov a zabezpečiť presmerovanie pôvodných webových adries Blogu na nové. Vskutku nepraktické a iba preto, aby kúpa modulu generovala pre PrestaShop zisk. Vo výsledku to ale môže obchodníka priviesť k úvahám k odchodu z platformy PrestaShopu. A to je potom pre PrestaShop tá najhoršia správa.

Vo svetle rastúcej konkurencie v oblasti predaja modulov a šablón vedenie PrestaShopu usúdilo, že sa zameria na generovanie zisku z ich predaja. Je to samozrejme potrebné, ak má firma monetizovať to, čomu sa venuje. Bohužiaľ, toto nasmerovanie spôsobilo, že PrestaShop prestal počúvať používateľov systému, developerov a firmy, ktoré tvoria celý ekosystém okolo platformy.

Tvrdohlavé a zlé rozhodnutia PrestaShopu spôsobili, že ani po 2 rokoch neexistuje oficiálny upgrade nástroj na prechod zo starších generácií systému na 1.7. Podľa nášho názoru je to veľké zlyhanie, pretože takýto nástroj mal byť vydaný súčasne s generáciou 1.7. Viete si predstaviť, že by napríklad Apple pri uvedení nového mobilného operačného systému neposkytol jednoduchý prechod zo starších verzií vrátane tej súčasnej a nabádal by súčasne použivateľov, aby si zakúpili nástroj niekoho iného, aby prechod umožnil?

Druhým fatálnym rozhodnutím bolo, že novú a nestabilnú generáciu začali označovať za stabilnú a obranou pred neprívetivou odozvou komunity bolo, že PrestaShop je bezplatný a keď ma niekto pripomienky, môže sa zapojiť do jeho vývoja, pretože to je Open Source projekt. Toto nesprávne pochopenie významu Open Source a Freeware pojmov spôsobili súčasnú nelichotivú nálepku pre PS 1.7. Vedenie PrestaShopu totiž prehliada fakt, že komunite neumožňuje aktívne ovplyvniť vývoj a funkcie systému, ktoré v ňom budú.

Bude riešením Thirty bees?

Najsilnejšóu odozvou nespokojnej komunity bol vznik vetvy PrestaShopu 1.6, ktorá sa volá Thirty bees (angl. 30 včiel). Dvaja americkí developeri, Michael Dekker a Lesley Paone sa rozhodli rozširovať a dopĺňať funkcionalitu PrestaShopu 1.6 na základe toho, čo komunita dlho do PrestaShopu požadovala a snažia sa okolo neho vytvoriť ekosystém modulov a šablón. Väčšina PrestaShop modulov je bez úpravy kompatibilných s Thirty bees. My sme sa rozhodli podporiť tento projekt prostredníctvom www.thirty-bees.sk

Náhla pozitívna zmena

PrestaShop zmenil rétoriku a možno je to signál, že v jeho vnútri prebieha proces sebareflexie a pochopil, že 1.6 je stále ich kľúčovým produktom. Na nedávnych PrestaShop Day v Paríži oficiálne oznámili, že plánovaná podpora 1.6 generácie neskončí 10/2018, ale budú ju podporovať a opravovať chyby systému až do doby, keď PrestaShop nebude kompletne prepísaný na framework Symfony. Takáto generácia môže niesť označenie 1.8, alebo až 2.0. Pri tempe vývoja systému to môže zabrať aj pár rokov.

Ak by totiž naozaj došlo k ukončením podpory 1.6 ako bolo plánované, spustili by process výraznej migrácie používateľov na iné platformy, čo by pocítili napríklad stratou zisku zo sprostredkovania predaja modulov, ale aj nefinačnou ujmou v podobe straty dôvery používateľov.

Dúfajme, že toto je jedna zo série prvých pozitívnych správ z tábora tvorcov PrestaShopu.

Obrázok: Vlákno diskusie z vývojárského blogu ohľadne predĺženia podpory PrestaShopu 1.6

Obrázok: Vlákno diskusie z vývojárského blogu ohľadne predĺženia podpory PrestaShopu 1.6.

Naše odporúčania pri voľbe verzie

Ak si chcete postaviť nový e-shop, siahnite po poslednej zostave PS 1.6 (aktuálne to je 1.6.1.20). Naozaj je to vo svete PrestaShopu najlepšie rozhodnutie kvôli stabilite systému.

Ak prevádzkujete staršiu generáciu systému, odporúčame kvôli súčasným serverovým nárokom (PHP, MySQL verzie, SSL certifikát, GDPR modul apod.) prechod na poslednú verziu 1.6. Zabezpečíte tak, že najbližšie roky nebudete musieť riešiť technické problémy a mať extra náklady na prevádzku systém. Neskôr, keď bude situácia okolo budúcich verzií jasnejšia a PrestaShop pripraví naozaj stabilný systém, prejdete na novšiu generáciu.

Ak ale nedopatrením máte e-shop postavený na 1.7 a riešenie technických problémov Vás zaťažuje do neúmernej miery, zvážte aj za cenu ďalších finančných a časových výdajov migráciu na 1.6.


Nasledujúci článok: Sledovacie URL pre dopravcov v PrestaShope
Predchádzajúci článok: Modul GDPR pre PrestaShop 1.6 a 1.7

Kategórie

Spojte sa s nami

PrestaShop a celý jeho ekosystém sa neustále vyvíja a napreduje. Prijímajte od nás e-mailom aktuality o najnovších vydaniach, moduloch a doplnkoch.